Previously, you could do "set pagetitle" to write the title for a page. Now it's been changed to topictitle. ...this means a whole lot of sed. I cd 'ed to data/Gunwiki and ran sed -i -e s/PAGETITLE/TOPICTITLE/g * personally. I have also modified to alert about TOPICTITLE now.

Installing a Captcha-based registration process

After being besieged by the spam pirates, I'm certainly not going without a captcha reg system again.

It would appear that CaptchaPlugin is still the only game in town, and there have been no updates. This is a huge pity, as I'd been hoping for some fixes that would make it easier for me to use it with my Comment feature.

I found that lib/TWiki/Plugins/ threw errors into the Apache error_log.

  • Add $ to debug at line 149

In lib/TWiki/UI/, it is necessary to tweak some things. Apparently TWiki's registration system changed the way it stored topics between 4.0 (when CaptchaPlugin was last updated) and 4.2, which is current as of today.

  • On line 1216, change $topic to $session->{topicName},

Issues with the Registration System

The trailing period after the code needs to be removed or ignored by the validation system. Double-clicking on it to select it for copy/paste results in the period being included, which results in a code failure.

Obsoleted things

  • The bread crumbs plugin's functionality is apparently now a part of TWiki's base config. No more need for a separate plugin. However, it does seem that the plugin version is superior in that it uses webhome to derive a more concise path (no self-referential garbage).

Enabling BBcode

For some reason, the BBcode plugin won't install from the Configure script. This may have something to do with the fact that it's only listed as compatible with TWiki 4.0 and 4.1. However, I found that after manually locating and downloading the zip file, the plugin functioned fine under 4.2.4.

Inline Javascript was disabled

Interestingly enough, the inline Javascript I'd had wasn't working. Tweaking with the file's script tag actually fixed it, but I'm not sure why - I think the damage may actually have been done by the stupid standard 4.2 editor, not the actual 4.2 system. Until I can figure out how to have a straight text editor like I had under 4.0, I may not be able to edit the JS pages outside of vi on the system.

Fixing the TreePlugin

I learned that lib/TWiki/Store/ was wrong in its error messages. {RCS}{WorkAreaDir} or whatever wasn't actually where the $dir variable was being derived from. So, it was necessary to readjust it. The bit immediately above it, where $dir was defined, is what needs to be corrected to be brought in line with the error message.

Thereafter, Configure threw an error informing me that TWiki had migrated the function, and I could delete the old directory. I did so, and the TreePlugin still worked.

-- SeanNewton - 25 Feb 2009

Edit | Attach | Watch | Print version | History: r4 < r3 < r2 < r1 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r4 - 2009-02-27 - SeanNewton
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2020 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback